Remove Black Frames From End of Looped DVD Architect Background Video

You’ve created a video that seamlessly loops from the end to the beginning and you want to use it for your menu background in DVD Architect.

But, when you add the video as the background video to your menu in DVD Architect, you discover that there’s a black frame or 2 at the end of your video. This showed up as an annoying black flash when you previewed the menu. At first, you thought maybe it was a playback issue. But, then you zoomed in on the video in DVD Architect and verified that there really is a black frame.

You go back to Sony Vegas and verify that loop point was set properly. It was.

Perhaps your audio was longer then the video and that forced the video to “stretch.” Nope. Your audio is exactly the same length as the video. That’s not it.

How do you fix it? You can’t leave it this way with the black frame. Why go the effort to make a looping menu background if you have to put up with a black frame at the end? Surely you don’t have to fade to black at the end just to get around this annoying behavior? That would be absurd.

The solution is to manually set the length of the menu background video in DVD Architect. Specifically, you need to make it a little shorter.
Menu length

In the example here, the menu length is 4:11:520. This is the value DVD Architect assigned to the menu when you added the video as the menu background. If you make the menu length just a little shorter, say 4:11.500, the black frame goes away and the video loops perfectly.

Advertisements